Buffer not found

I am getting below error

java -jar snowplow-stream-collector-kinesis-1.0.0.jar --config /home/ubuntu/snowplow/2-collectors/scala-stream-collector/examples/config.hocon.conf

Exception in thread "main" pureconfig.error.ConfigReaderException: Cannot convert configuration to a com.snowplowanalytics.snowplow.collectors.scalastream.model.CollectorConfig. Failures are:
  at the root:
    - (file:/home/ubuntu/snowplow/2-collectors/scala-stream-collector/examples/config.hocon.conf:20) Key not found: 'rootResponse'.
  at 'streams':
    - (file:/home/ubuntu/snowplow/2-collectors/scala-stream-collector/examples/config.hocon.conf:145) Key not found: 'buffer'.

        at pureconfig.package$.getResultOrThrow(package.scala:139)
        at pureconfig.package$.loadConfigOrThrow(package.scala:195)
        at com.snowplowanalytics.snowplow.collectors.scalastream.Collector.parseConfig(Collector.scala:67)
        at com.snowplowanalytics.snowplow.collectors.scalastream.Collector.parseConfig$(Collector.scala:43)
        at com.snowplowanalytics.snowplow.collectors.scalastream.KinesisCollector$.parseConfig(KinesisCollector.scala:24)
        at com.snowplowanalytics.snowplow.collectors.scalastream.KinesisCollector$.main(KinesisCollector.scala:27)
        at com.snowplowanalytics.snowplow.collectors.scalastream.KinesisCollector.main(KinesisCollector.scala)

Below is my config file

collector {

interface = "0.0.0.0"

  port = 8080

  paths {

    # "/com.acme/track" = "/com.snowplowanalytics.snowplow/tp2"

    # "/com.acme/redirect" = "/r/tp2"

    # "/com.acme/iglu" = "/com.snowplowanalytics.iglu/v1"

  }

  p3p {

    policyRef = "/w3c/p3p.xml"

    CP = "NOI DSP COR NID PSA OUR IND COM NAV STA"

  }
  crossDomain {

    enabled = false
    domains = [ "*" ]
    secure = true

  }

  cookie {

    enabled = true

    expiration = "365 days" # e.g. "365 days"

    name = snowplow
 

    domains = [ "*" ]

    secure = false

    httpOnly = false

  }

  doNotTrackCookie {

    enabled = false

    name = ""

    value = ""

  }

  cookieBounce {

    enabled = false 

    name = "n3pc"

    fallbackNetworkUserId = "00000000-0000-4000-A000-000000000000"

    forwardedProtocolHeader = "X-Forwarded-Proto"

  }

  enableDefaultRedirect = true

  redirectMacro {

    enabled = false

  }

  cors {

        accessControlMaxAge = 5 seconds

  }



  prometheusMetrics {

    enabled = false

  }

  streams {

    good = com.caroffer.snowplow.events.good

    bad = com.caroffer.snowplow.events.bad

  

    useIpAddressAsPartitionKey = false

      sink {


      enabled = kinesis

      region = us-east-1

     threadPoolSize = 10

      
      aws {

        

        accessKey = abcd
        secretKey = abcd

      }

      # Minimum and maximum backoff periods, in milliseconds

      backoffPolicy {

        minBackoff = 3000

        maxBackoff = 600000

      }

    buffer {
    

      byteLimit = 4500000

      recordLimit = 500

      timeLimit = 60000

    }

  }

}


akka {

  loglevel = DEBUG # 'OFF' for no logging, 'DEBUG' for all logging.

  loggers = ["akka.event.slf4j.Slf4jLogger"]

  http.server {


    remote-address-header = on

    raw-request-uri-header = on

    

    # Define the maximum request length (the default is 2048)

    parsing {

      max-uri-length = 32768

      uri-parsing-mode = relaxed

      

    }

  }
}
}

Could you paste your configuration within a code block? You can use three backticks (```) at the starting line and ending line which will format the block correctly.

Thanks for the response the issue got fixed