Cannot read uploaded schema in Snowplow Mini


#1

Hey, I’m trying to create my custom schema on snowplow mini, but it doesn’t work.
i’ve tried dig to the postgres database on schema table, and the schema is there, also i’ve check on my iglu schema web (ip:8081) and it shows my schema, got no idea why this is happening

Here is some details about it

Collector:

   window.snowplow('trackUnstructEvent', {
             schema: 'iglu:com.achme/event_name/jsonschema/1-0-0',
             data: {
                 "form_id":"asd"
             }   
         });

The Schema :

{
	"$schema": "http://iglucentral.com/schemas/com.snowplowanalytics.self-desc/schema/jsonschema/1-0-0#",
	"description": "The Description",
	"self": {
		"vendor": "com.achme",
		"name": "event_name",
		"format": "jsonschema",
		"version": "1-0-3"
	},
	"type": "object",
	"properties": {
		"formId": {
			"type": "string"
		}
	},
	"required": ["formId"],
	"additionalProperties": true
}

Problems:

[{"message":"error: Could not find schema with key iglu:com.achme/event_name/jsonschema/1-0-3 in any repository, tried:\n level: \"error\"\n repositories: [\"Iglu Central [HTTP]\",\"Iglu Client Embedded [embedded]\",\"Iglu Server [HTTP]\"]\n","level":"error"}]

Iglu Resolver:

{
  "schema": "iglu:com.snowplowanalytics.iglu/resolver-config/jsonschema/1-0-0",
  "data": {
    "cacheSize": 500,
    "repositories": [
      {
        "name": "Iglu Central",
        "priority": 2,
        "vendorPrefixes": [
          "com.snowplowanalytics"
        ],
        "connection": {
          "http": {
            "uri": "http://iglucentral.com"
          }
        }
      },
      {
        "name": "Iglu Server",
        "priority": 1,
        "vendorPrefixes": [
          "com.snowplowanalytics",
          "com.achme",
          "com.achme.test"
        ],
        "connection": {
          "http": {
            "uri": "http://localhost:8081/api"
          }
        }
      }
    ]
  }
}

Thanks~


#2

@Spycomb,

@yali recently responded to a similar issue on a previous thread:

See his response in this post.


#3

HI, thank you for your reply,
yep, i’ve seen those post yesterday, it was my bad to not clearly search the forum before i post

Thank You :wink: