Enricher high CPU utilisation issue

Hi @BenB
we are running below command for enricher
sudo docker run -d -v /snowplow/config:/snowplow/config snowplow-docker-registry.bintray.io/snowplow/stream-enrich-kinesis:0.21.0 --config /snowplow/config/enrich.hocon --resolver file:/snowplow/config/resolver.json --enrichments file:/snowplow/config/enrichments/ --force-cached-files-download

Regarding the stats will update you soon

Hi @karan,

Latest enrich version is 1.3.1. It’s available directly on Docker Hub. We recommend to use this version. Please note that it comes with a new format for the bad rows emitted by enrich. You can read about it on this blog post.

The upgrade guides until this version can be found here.

Thanks @BenB will definitely use 1.3.1 and let you know

Hi @BenB

I tried 1.3.1 in that I am getting CPU utilisation as well as sql enricher failure issue both.

{"schemaKey":"iglu:com.snowplowanalytics.snowplow.enrichments/sql_query_enrichment_config/jsonschema/1-0-0","identifier":"sql-query"},"message":{"error":"The placeholder map error. The map: Some(IntMap()), where count is: 1"}}]}

Hi @karan,

Sorry for getting back and forth, but we recently realised that SQL Enrichment bug wasn’t get fixed in 1.3.1, please give a try to a fresh 1.3.2.

However, I’m bit puzzled by CPU utilisation bug as it did certainly go away in 1.3.x branch in our experience.

Hi @anton,

Thanks for the SqlEnrichment Fix… 1.3.2 is working fine for Sql Enrichments now.

But CPU utilisation issue is still there. I tried 1.3.2 by removing Sql enrichment as well but there is no improvement in CPU utilisation, it keeps on getting over 100%.