Getting emitters[i] undefined when using the node.js tracker in react-native

#1

Hi -

I’m using the node.js tracker in my react-native app and I’m getting the following error: emitters[i] is undefined. I found this github issue that had the same problem: https://github.com/snowplow/snowplow/issues/3182 but the user didn’t receive any suggestions.

I followed the node.js tracker setup guide to a tee and am still getting errors.

#2

Hi @postfactum, it looks like there was some advice in the issue you linked - let me know if that addresses the problem (I’ll update the documentation in that case, since it seems like things are outdated), if not I’m happy to help.

#3

@mhadam Hey - The advice VanHoutte gave me on the issue I linked worked perfectly. Thanks for the reply.