Java 7 is no longer downloadable when firing up Snowplow using Vagrant


#1

I am following the Quickstart instructions to fire up Snowplow. When running the Ansible oss-playbook java7.yml, I receive the following error:

==> default: Connecting to download.oracle.com (download.oracle.com)|65.202.184.99|:80... connected.
==> default: HTTP request sent, awaiting response... 404 Not Found
==> default: 2017-05-31 21:18:21 ERROR 404: Not Found.
==> default: 
==> default: download failed
==> default: Oracle JDK 7 is NOT installed.

Doing some reading on the topic, it seems as though Oracle moved the Java 7 download. I tried to move to java8.yml, which works, but breaks tests.

Has the Ansible playbook for Java7 been fixed? Or should I go through the process of fixing tests for Java8?

Thanks


HTTPS Handshake Failure during API enrichment
#3

BTW - it looks like Java 7 is no longer supported the way it is installed in the Snowplow Vagrant method.

I assume that Java 8 should be the version by default.


#4

Hi @switzer,

To start firing up Snowplow, I would advise following the instructions on the wiki page: https://github.com/snowplow/snowplow/wiki/Setting-up-Snowplow.

You do not have to build the application, the executables are available to download as explained on the following pages (for batch pipeline setup):

All the best!


#5

Or just change the playbook to java8.yml


#6

Yeah, but Snowplow hasn’t been tested with Java 8, and I ran into one issue already: HTTPS Handshake Failure during API enrichment


#8

Java 8 is right around the corner for the batch pipeline with R89 which is the next release of Snowplow, you can follow our progress here: https://github.com/snowplow/snowplow/pull/3203.