Load to PostgreSQL failing


#1

Running snowplow r97 knossos via command:
snowplow-emr-etl-runner run -c config/config.yml -r config/iglu_resolver.json -t config/targets

This postgres.json is the targets folder:
{
“schema”: “iglu:com.snowplowanalytics.snowplow.storage/postgresql_config/jsonschema/1-1-0”,
“data”: {
“name”: “PostgreSQL enriched events storage”,
“host”: “mydomain.com”,
“database”: “snowplow”,
“port”: 5432,
“sslMode”: “DISABLE”,
“username”: “storageloader”,
“password”: “mypassword”,
“schema”: “atomic”,
“sshTunnel”: null,
“purpose”: “ENRICHED_EVENTS”
}
}

I’ve setup PostgreSQL to listen on all addresses and have added host all storageloader 0.0.0.0/0 md5 to the pg_hba.conf on my remote server.

Error message:
SEVERE: Connection error:
org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host “18.216.16.68”, user “storageloader”, database “snowplow”, SSL off

S3 Log File:

AccessDenied
Access Denied
B272B7583D0D32D4

42GyVZgCRUrS5YvW2ZPvAtwB/adIsHg8DBFDJj9tBtnFBvC4d9FIdH6DVc8Uki4XOFriZoGwkNc=

Any advice is appreciated. Thanks in advance!


#2

Hey @starleaf - that error message generally pops up when the database you are connecting to requires SSL. As a first step you could try changing sslMode to REQUIRE instead of DISABLE.