Problems with set-up enrichment/ emretlrunner for first time


#1

Hi all,

We are trying to set-up snowplow for the first time, but are getting stuck at the enrichment step. The process we followed is:

  1. We set-up a cloudfront collecter, we created a bucket and installed a tracking pixel. We created a bucket for the logs and tested this and it worked.
  2. We installed a javascript pageview tracker (through GTM).
  3. We installed the EMLetlrunner. And create a file with the following lay-out: https://prnt.sc/j7daye
  4. Our bucket layout in S3 looks as follows:
  • moongro (containing pixel)
  • moongrologfiles (containing logs)
  • snowplow.data
    - snowplow.data/archive/
    - snowplow.data/archive/enriched
    - snowplow.data/archive/enriched/bad
    - snowplow.data/archive/enriched/good
    - snowplow.data/archive/raw
    - snowplow.data/archive/shredded
    - snowplow.data/archive/shredded/bad
    - snowplow.data/archive/shredded/good
    - snowplow.data/processing
  1. The code of our YAML config file (not sure how to put it in one of those grey blocks):
    aws:
    access_key_id: XXX
    secret_access_key: XX
    s3:
    region: eu-west-1
    buckets:
    assets: s3://snowplow-hosted-assets # DO NOT CHANGE unless you are hosting the jarfiles etc yourself in your own bucket
    jsonpath_assets: # If you have defined your own JSON Schemas, add the s3:// path to your own JSON Path files in your own bucket here
    log: s3://moongrologfiles/logs/
    raw:
    in: # This is a YAML array of one or more in buckets - you MUST use hyphens before each entry in the array, as below
    - s3://moongrologfiles # e.g. s3://my-old-collector-bucket
    processing: s3://snowplow.data/processing
    archive: s3://snowplow.data/archive/raw # e.g. s3://my-archive-bucket/raw
    enriched:
    good: s3://snowplow.data/enriched/good # e.g. s3://my-out-bucket/enriched/good
    bad: s3://snowplow.data/enriched/bad # e.g. s3://my-out-bucket/enriched/bad
    errors: # Leave blank unless :continue_on_unexpected_error: set to true below
    archive: s3://snowplow.data/archive/enriched # Where to archive enriched events to, e.g. s3://my-archive-bucket/enriched
    shredded:
    good: s3://snowplow.data/shredded/good # e.g. s3://my-out-bucket/shredded/good
    bad: s3://snowplow.data/shredded/bad # e.g. s3://my-out-bucket/shredded/bad
    errors: # Leave blank unless :continue_on_unexpected_error: set to true below
    archive: s3://snowplow.data/archive/shredded # Where to archive shredded events to, e.g. s3://my-archive-bucket/shredded
    emr:
    ami_version: 5.9.0
    region: eu-west-1 # Always set this
    jobflow_role: EMR_EC2_DefaultRole # Created using aws emr create-default-roles service_role: EMR_DefaultRole # Created using aws emr create-default-roles
    placement: # Set this if not running in VPC. Leave blank otherwise
    ec2_subnet_id: # Set this if running in VPC. Leave blank otherwise
    ec2_key_name: moongro
    bootstrap: [] # Set this to specify custom boostrap actions. Leave empty otherwise
    software:
    hbase: # Optional. To launch on cluster, provide version, “0.92.0”, keep quotes. Leave empty otherwise.
    lingual: # Optional. To launch on cluster, provide version, “1.1”, keep quotes. Leave empty otherwise.
    jobflow:
    job_name: Snowplow ETL # Give your job a name
    master_instance_type: m1.medium
    core_instance_count: 2
    core_instance_type: m1.medium
    core_instance_ebs: # Optional. Attach an EBS volume to each core instance.
    volume_size: 100 # Gigabytes
    volume_type: “gp2”
    volume_iops: 400 # Optional. Will only be used if volume_type is “io1”
    ebs_optimized: false # Optional. Will default to true
    task_instance_count: 0 # Increase to use spot instances
    task_instance_type: m1.medium
    task_instance_bid: 0.015 # In USD. Adjust bid, or leave blank for non-spot-priced (i.e. on-demand) task instances
    bootstrap_failure_tries: 3 # Number of times to attempt the job in the event of bootstrap failures
    configuration:
    yarn-site:
    yarn.resourcemanager.am.max-attempts: “1”
    spark:
    maximizeResourceAllocation: “true”
    additional_info: # Optional JSON string for selecting additional features
    collectors:
    format: cloudfront # For example: ‘clj-tomcat’ for the Clojure Collector, ‘thrift’ for Thrift records, ‘tsv/com.amazon.aws.cloudfront/wd_access_log’ for Cloudfront access logs or ‘ndjson/urbanairship.connect/v1’ for UrbanAirship Connect events
    enrich:
    versions:
    spark_enrich: 1.13.0 # Version of the Spark Enrichment process
    continue_on_unexpected_error: false # Set to ‘true’ (and set :out_errors: above) if you don’t want any exceptions thrown from ETL
    output_compression: NONE # Compression only supported with Redshift, set to NONE if you have Postgres targets. Allowed formats: NONE, GZIP
    storage:
    versions:
    rdb_loader: 0.14.0
    rdb_shredder: 0.13.0 # Version of the Spark Shredding process
    hadoop_elasticsearch: 0.1.0 # Version of the Hadoop to Elasticsearch copying process
    monitoring:
    tags: {} # Name-value pairs describing this job
    logging:
    level: DEBUG # You can optionally switch to INFO for production
    snowplow:
    method: get
    app_id: snowplow # e.g. snowplow
    collector: dmpjpaamkv337.cloudfront.net # e.g. d3rkrsqld9gmqf.cloudfront.net

  2. When in the terminal I run this:
    Compleet/snowplow-emr-etl-runner -c config/config.yml -r config/iglu_resolver.json

I get this message:

unsupported Java version “10”, defaulting to 1.7
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.jruby.util.io.FilenoUtil (file:/var/folders/d3/hsfz4yw55ll43zkjy5xkfr400000gn/T/jruby10517382362522483489extract/jruby-core-9.1.7.0-complete.jar) to method sun.nio.ch.SelChImpl.getFD()
WARNING: Please consider reporting this to the maintainers of org.jruby.util.io.FilenoUtil
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Configuration file ‘config/config.yml’ does not exist, or is not a file
Usage: run [options]
-c, --config CONFIG configuration file
-n, --enrichments ENRICHMENTS enrichments directory
-r, --resolver RESOLVER Iglu resolver file
-t, --targets TARGETS targets directory
-d, --debug enable EMR Job Flow debugging
-f {enrich,shred,elasticsearch,archive_raw,rdb_load,analyze,archive_enriched,archive_shredded},
–resume-from resume from the specified step
-x {staging,enrich,shred,elasticsearch,archive_raw,rdb_load,consistency_check,analyze,archive_enriched,archive_shredded},
–skip skip the specified step(s)
-i, --include {vacuum} include additional step(s)
-l, --lock PATH where to store the lock
–consul ADDRESS address to the Consul server

Not sure what I am doing wrong, but all folders are still empty after running this. What am I doing wrong? Would greatly appreciate help. We were following the guide: https://github.com/snowplow/snowplow/wiki/Setting-up-Snowplow but must’ve made a mistake somewhere.

Thanks in advance!

Tjadi


#2

Make sure you’re running under Java 7 or 8 rather than 10.

You’ll also want to use tsv/com.amazon.aws.cloudfront/wd_access_log for the format parameter rather than cloudfront.


#3

Thanks! That worked. Now I am getting the following error/ notification:
Configuration file ‘config/config.yml’ does not exist, or is not a file
Do you know what causes this? I have the configuration file saved as ‘config.yml’ in the config folder.

Have a nice day.


#4

Already figured it out, it was a mistake in the command line.