Redshift SSL connection resetting


#1

I’ve just started getting into Snowplow and have everything running the way I want. I just enabled SSL on my Redshift cluster (parameter group “require_ssl = true”) and I can connect into my cluster fine over JDBC as well as the Storage-Loader being able to load enriched events into Redshift. However, the SQL-Runner app refuses to make a connection. I’ve done as prescribed and added: ssl: true in my playbooks. The error I’m getting is:

read: connection reset by peer

I am running the version 0.5.0 of the SQL-Runner on my EC2 instance. Any help would be appreciated.


#2

Hi @mialberhasky - that’s odd, your setup is exactly how we run SQL Runner for customers with SSL-enabled Redshift.

I’m wondering if there’s a regression in SQL Runner v0.5.0 - can you try an earlier version?


#3

Going back to SQL-Runner v0.4.0 fixed the problem.


#7

Hi @mialberhasky it looks there is indeed a regression in the latest release - quite probably to do with the upgrade of the underlying PSQL library we use. I will have a look into it and see what we can do about fixing it!

I have created a ticket and milestone to track the issue:

Cheers,
Josh


#8

Hey @mialberhasky I have published a 0.5.2-rc1 which should hopefully resolve the TLS issues you have been seeing. If you wouldn’t mind grabbing down a copy and giving it a test drive:

https://bintray.com/snowplow/snowplow-generic/sql-runner/0.5.2-rc1#files

Cheers,
Josh


#9

Seems to work. I was able to execute a playbook with SSL.


#10

Thanks @mialberhasky! Will get the fixes merged.

Cheers,
Josh