Snowplow Mini Setup // Bad Gateway


#1

Hey Guys,

Trying to setup a Snowplow mini instance and running into some snags. Each time I get the instance up and running, but can’t seem to get the Swagger UI setup correctly.

Also, I should mention I’m a product guy with a decent amount of technical knowledge, but don’t work much with AWS, so apologies if I’m missing assumptions more technical folks make : ) Thanks in advance for your patience.

I’m thinking that it has something to do with the security group setup (mine below):

Steps to repro:

  1. Launch instance according to setup guide
  2. After instance launches, I’m allocating and associating an elastic IP address to the instance since eventually I’d like to point a subdomain there ie data.ourcompany.com -> elastic IP
  3. I’m able to change the basic auth and upload an API key just fine. Refresh browser and login with new credentials
  4. I then get to this step: https://github.com/snowplow/snowplow-mini/wiki/Usage-guide#26-setting-baseurl-for-swagger-ui-optional
  • Download the default Iglu Server Config file and make the following changes:
    repo-server {
    interface = “{{elastic_ip}}”
    baseURL = “{{elastic_ip}}/iglu-server”
    port = 8081
    }
  1. Upload the conf file via the UI - no errors
  2. I then click the link which resolves to http://{{elastic_ip}}/iglu-server/

Expected:
Swagger UI renders

Actual:
Get a 502 Bad Gateway response

Any help much appreciated! Excited to get this up and running.


#2

Bump. Anyone have insight?


#3

Hi @phjohnson,

In your altered config you should only be changing the “baseURL” value not the “interface” value. The interface is where the Iglu Server is going to bind internally - this should remain as 0.0.0.0 for it to work correctly.

Hope this helps!


#4

Thank you @josh! That did the trick. :raised_hands:

Much appreciated!